V reg 1.0 Inspiration, no spark.

Hi, I have a V-reg Inspiration (stock clearance, end of line special?:)) which suddenly refused to start. It had been running fine just an hour or so beforehand.
I have the Haynes manual for it and have so far done the following:

Tried jump-start - engine cranks fine, but not starting.

Checked spark - tested by laying a known good plug onto the engine and connecting a lead whilst cranking. No spark.

Consulted Haynes - tried diagnostic check. No idea what they are referring to about an LED on the module under the dash - there is no LED there!
Also, the engine management light is on constantly, but the AIRBAG light flashes when I try to go into diagnostic mode by flashing the bottom left 2 pins. - is this actually a fault code display in this model? (Haynes do not mention the airbag light)

Assuming the airbag light is giving me a code, it says the crank angle sensor is not being read. - took off distributor and checked for 5v-0v switching, which it does OK (also triggers the injectors if fuse left in by accident :))

So, I guess my three questions are:
1) Is this model of Micra using its airbag light to display the fault code?
2) Is it likely that the dizzy has suddenly died in such a way as to appear to work, but not?
3) Is it likely to be something else from the symptoms I have described?